PIF - Paying It Forward

Technical Board => Motorcycle Technical => Topic started by: Hick on October 09, 2013, 06:10:36 PM



Title: Fuel Pump Relay - I'm cornfused!
Post by: Hick on October 09, 2013, 06:10:36 PM
When I told him I had a defective fuel pump, the fellow at the parts store asked me if I had enough power going to the pump.  Sure, it's cranking over very good, plenty of voltage.

The replacement pump is running just as poorly.  >:(

Then this morning (about 4:30 AM) I got to thinking;  just because the battery has 12.5 volts does not mean it is getting to the pump.

So tonight after work, decided to do some more troubleshooting.  Took the wire off the pump and applied full battery charger voltage to the pump.  Ran like a top!

Checked voltage at the pump wire, about 1 volt low.  Loosing that much will also kill the amps going to it.  Searched through the two pages of wiring diagram (to run a fuel pump?!?!?!!??!?!?!?!).  Found the relay (good info on where to find it in the book!)   Unplugged it to check the wiring.  THE PUMP RUNS W/O THE RELAY BEING PLUGGED IN!  From looking at the wiring diagram, this should NOT be!

Any ideas?  I know a short is possible, but doubtful.  Has anyone else run into this?


Title: Re: Fuel Pump Relay - I'm cornfused!
Post by: Jerry Fouquette on October 10, 2013, 06:40:45 AM
It's too late for my advice.  Next time buy a bike that already runs and ride it!   (x*


Title: Re: Fuel Pump Relay - I'm cornfused!
Post by: John Anderson on October 10, 2013, 08:52:35 AM
Where do I find the fuel pump??  ;)