PIF - Paying It Forward
November 18, 2019, 04:58:28 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: "We ride because we see long lines of cars and trucks, creeping along toward another day, a crummy one just like yesterday. We ride by, glance into those cars and trucks and can't imagine being one of THEM, when we could be, we ARE, one of us." - Maynard Hershon, Citybike, 9/05
 
   Home   Help Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Hey Greg  (Read 2924 times)
Littlejoe_N_Tn
Full Member
***
Offline Offline

Posts: 114


« on: August 18, 2012, 04:28:49 PM »

What was wrong with you GL1800 when you had to the motor pulled?

Thanks,
HT
Logged

<center>
<a href="http://www.mytriplogs.com" target="_blank">
<img src="http://www.mytriplogs.com/sigs/mtl_create_us_states_map.php?rz=75&amp;vu=vuvvvvvvvvvuuvvvvvvuvuvuvvvvvuvvvvuvvuvvuvvvvuvuvuv" border="0"></img>
<br>Free, personalized travel maps at mytriplogs.com</a>
<br>
</center>
iwing
Administrator
Hero Member
*****
Offline Offline

Posts: 3667



« Reply #1 on: August 23, 2012, 06:38:06 AM »

The initial problem the alt drive gears broke. Engine must be pulled for that. Then they found my frame was cracked & I had the frame replaced.
Logged

iwing
Administrator
Hero Member
*****
Offline Offline

Posts: 3667



« Reply #2 on: July 02, 2013, 02:47:46 AM »

It's all here. http://gl1800riders.com/forums/showthread.php?246040-My-03-just-developed-a-nasty-noise
Logged

Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!